Channel Icons and Names

pdragon
Posts: 8
Joined: Sat Sep 15, 2007 11:14 pm

Channel Icons and Names

Post by pdragon »

Two questions... first is I was wondering if SD would be providing any kind of service to allow use to get channel icons? I tried using the perl script from XMLTV, but apparently it used to scrape zaq2it's site to get them and isn't working anymore (or I'm doing something wrong).

The other question is, I did the scan for all my channels during MythTV setup and it gave all my channel names a name of "Adding Channel 2", "Adding Channel 3", etc. I thought after downloading my schedule information it would give my channel names something more meaningful. Is there a way to do this automatically using SD and MythTV or do I have to go name all the channels myself?

Thanks in advance and thanks for lowering the price!

rmeden
SD Board Member
Posts: 1563
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX
Contact:

Re: Channel Icons and Names

Post by rmeden »

You're welcome. I just tried tv_grab_na_icons and it worked fine. (current version)

Robert

Knight
Posts: 17
Joined: Mon Aug 20, 2007 8:16 pm

Re: Channel Icons and Names

Post by Knight »

pdragon wrote:The other question is, I did the scan for all my channels during MythTV setup and it gave all my channel names a name of "Adding Channel 2", "Adding Channel 3", etc. I thought after downloading my schedule information it would give my channel names something more meaningful. Is there a way to do this automatically using SD and MythTV or do I have to go name all the channels myself?
Hi!

I believe you are supposed to fetch the channels from source and not actually scan them but doing a:

mythfilldatabase --do-channel-updates

should correct your problem

Re (from the help page of mythfilldatabase):
--do-channel-updates
When using DataDirect, ask mythfilldatabase to
overwrite channel names, frequencies, etc. with the
values available from the data source. This will
override custom channel names, which is why it is
off by default.
Good luck!

Nick

danielk
SD Board Member
Posts: 62
Joined: Tue Aug 14, 2007 2:40 pm

Re: Channel Icons and Names

Post by danielk »

Two questions... first is I was wondering if SD would be providing any kind of service to allow use to get channel icons? I tried using the perl script from XMLTV, but apparently it used to scrape zaq2it's site to get them and isn't working anymore (or I'm doing something wrong).
SD will probably not offer such an icon service in the future. But I know there are discussions being held outside of SD about how to officially license channel icons for various PVR and listings program purposes; I don't know how much I can talk about that.
The other question is, I did the scan for all my channels during MythTV setup and it gave all my channel names a name of "Adding Channel 2", "Adding Channel 3", etc. I thought after downloading my schedule information it would give my channel names something more meaningful. Is there a way to do this automatically using SD and MythTV or do I have to go name all the channels myself?
When using Schedules Direct for analog of sources, you should not scan for channels. The channel scanner for analog channels is there at the request of people in parts of Europe where there is no SD equivalent. With Schedules Direct your analog channels are added based on the listings data. I'm working on a new UI for adding channels where the recommended procedure should be more obvious.

pdragon
Posts: 8
Joined: Sat Sep 15, 2007 11:14 pm

Re: Channel Icons and Names

Post by pdragon »

I re-ran the MythTV Setup and pulled the Channels from the Listing Source and it looked like it grabbed all the channel names properly in the Channel Editor. But when I went back into the Frontend, a lot of the channels were off; some were off by two channels others were fine. Example: Discovery is channel 15, but it was being listed as channel 13 in the Program Guide. Tuning to channel 15 properly brings up Discovery, but it's label is wrong. This also caused my scheduled programs to have their channels changed if they were one of the wrongly labeled ones. Back in the Channel Editor, everything looked to be labeled properly, so not sure what's happened during the mythfilldatabase run after I exit out of setup. I went back and did the Channel Scanner and now everything is lined up properly, but I'm back to the "Adding Channel X" labels. I'm wondering if doing the Channel Scanner initially might have messed things up. I'm still testing and learning this thing, so I might just reload it from scratch and do it right the first time to see if that fixes it.

Haven't had a chance to go back and try and get the icons yet.

pdragon
Posts: 8
Joined: Sat Sep 15, 2007 11:14 pm

Re: Channel Icons and Names

Post by pdragon »

Got it all fixed! I ran Myth Setup again and this time I :
- deleted my Video Source as well as all Channel Listings
- recreated the Video Source and put my SD info in
- fetched the channels from the listing provider (did not touch the channel scanner). This is a bit confusing and may have been why I tried the Channel Scanner. When you use the option to fetch from SD, it gives no indication that anything is going on, but if you just let it go for a few seconds, it does get the channel info. Going to the Channel Editor confirms it worked.
- exited and ran the database update

Now all the channels are labeled properly and the program guide is working fine. Now onto the channel icons!

pdragon
Posts: 8
Joined: Sat Sep 15, 2007 11:14 pm

Re: Channel Icons and Names

Post by pdragon »

rmeden wrote:You're welcome. I just tried tv_grab_na_icons and it worked fine. (current version)

Robert
I tried using the XMLTV that's in Ubuntu 7.04 Synaptic, but I don't think it includes the new info for Schedules Direct. So, I went to get XMLTV right from the source but I cannot get the perl modules required to configure for the north american icons to install, specifically WWW::Mechanize. It fails the tests it runs during CPAN install. I tried installing via Synaptic and even forced the install in CPAN, but XMLTV just isn't seeing that module installed.

How did you get the current XMLTV installed and configured to install the icons?

rmeden
SD Board Member
Posts: 1563
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX
Contact:

Re: Channel Icons and Names

Post by rmeden »

I think installed the Perl modules from CPAN.. even got it to work on Windows. :)

na_icons hasn't changed since 0.5.46.

Robert

pdragon
Posts: 8
Joined: Sat Sep 15, 2007 11:14 pm

Re: Channel Icons and Names

Post by pdragon »

Yeah, and the latest xmltv from Ubuntu 7.04 repositories is 5.44 which doesn't have the new update for SD support. Looks like even 7.10 only has 5.45. So, I've been trying to do it from source, but CPAN just ain't cooperating with the ONE module I need. :|

theminor
Posts: 3
Joined: Fri Sep 28, 2007 7:43 am

Re: Channel Icons and Names

Post by theminor »

I'm also running Ubuntu under a new mythtv install. I can't get the icons to work with mkiconmap.pl - it says I have an invalid zip code, I think because it calls xmltv tv_grab_na. I sure would like to get the icons working. Can anyone post instructions as to how to get icons up and working with mythtv on ubuntu? Thanks in advance!

Post Reply