The remote server returned an error: (500) Internal Server Error

Forum rules
Get Help using the Schedules Direct service. NOTE: application issues are probably better resolved via the application's support methods. If you post here, at least include your application name!
Post Reply
rickgillyon
Posts: 6
Joined: Sat Dec 16, 2017 7:21 am

The remote server returned an error: (500) Internal Server Error

Post by rickgillyon »

I've tried 3 different clients to download xml this morning, and all of them are getting errors from SD, such as:
[06/06/2020 13:44:26] [ INFO] SD API WebException Thrown. Message: The remote server returned an error: (500) Internal Server Error. , Status: ProtocolError

If I grab only one channel, no problem, but as soon as there's a decent amount of data, bang. I've tried EPG123, Guide2Go and TVHeadend's grabber, all failing. Is there a problem with the JSON service?

Cyrano
Posts: 2
Joined: Mon Apr 20, 2020 8:16 am

Re: The remote server returned an error: (500) Internal Server Error

Post by Cyrano »

Here's my error report on the same issue:
[6/6/2020 6:08:42 AM] [ INFO] Token request successful. serverID: 20141201.web.3
[6/6/2020 6:08:42 AM] [ INFO] Status request successful. account expires: 2020-08-22T00:58:32Z , lineups: 1/4 , lastDataUpdate: 2020-06-06T04:23:00Z
[6/6/2020 6:08:42 AM] [ INFO] system status: Online , message: No known issues.
[6/6/2020 6:08:42 AM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[6/6/2020 6:08:43 AM] [ERROR] SD API Unknown exception thrown. Message: Unable to read data from the transport connection: The connection was closed.
[6/6/2020 6:08:43 AM] [ERROR] Did not receive a response from Schedules Direct for retrieval of lineup USA-WA46459-X.
[6/6/2020 6:08:43 AM] [ INFO] Successfully queried the Task Scheduler for status. Ready. Last Run 6/6/2020 5:00:00 AM; Exit: 0x00000000

rickgillyon
Posts: 6
Joined: Sat Dec 16, 2017 7:21 am

Re: The remote server returned an error: (500) Internal Server Error

Post by rickgillyon »

They've restarted some services, should be working now.

Post Reply