SD JSON authentication error when useing MC2XML

Forum rules
Get Help using the Schedules Direct service. NOTE: application issues are probably better resolved via the application's support methods. If you post here, at least include your application name!
Post Reply
Prkbro
Posts: 2
Joined: Sun Apr 19, 2020 9:51 am

SD JSON authentication error when useing MC2XML

Post by Prkbro »

Hi,

I just noticed the SD JSON server maintenance notifications
. Wondering if the SD team can confirm whether or not the maintenance will resolve issues I've been experiencing for at least past month when trying to pull program data using MC2XML...

Issue is using MC2XML (latest ver available) to pull guide data via SD JSON worked fine for more a couple weeks. Then, all of the sudden, I began getting authentication errors whenever my scheduled task ran to pull new data. i immediately went to the SD website and successfully logged in using credentials in my schedule task's script but I reset my SD password anyway. Re-ran MC2XML again and same issue. Has been this way, SD JSON service completely broken, for a month... however I fell back to using the SD legacy service. Well, as of this morning, the legacy service is broken for me as well. Same exact issue as before - authentication fails when running MC2XML to retrieve program data using SD legacy service.

I'm really hoping the SD server maintenance resolves all of my authentication issues but if not, how do I escalate this? Because currently I'm completely unable to get any program data. :-(

Thanks in advance for any assistance.

rmeden
SD Board Member
Posts: 1569
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX
Contact:

Re: SD JSON authentication error when useing MC2XML

Post by rmeden »

There have been no changes to the legacy SD-DD service and it continues to run fine. Make sure you log in with your username not email. Maybe you have special characters in your password that MC2XML isn't handling properly?

Prkbro
Posts: 2
Joined: Sun Apr 19, 2020 9:51 am

Re: SD JSON authentication error when useing MC2XML

Post by Prkbro »

rmeden wrote:
Sun Apr 19, 2020 1:05 pm
There have been no changes to the legacy SD-DD service and it continues to run fine. Make sure you log in with your username not email. Maybe you have special characters in your password that MC2XML isn't handling properly?
rmeden,

Thanks for the quick reply. My SD password has no special characters that MC2XML could not handle - I've read over the caveats/recommendations for that software over and over thinking I overlooked something but all is good.

Ironically I hadn't checked for any updates to the MC2XML program.. behold I was 2 versions behind (using 1.7.0 vs newest 1.7.2). Ran latest and it worked with SD Legacy service. So, hoping JSON service works whenever it comes back up.

Again, thanks for the fast response!

Post Reply