Tribune having problems, empty <PROGRAMS> section

Forum rules
Get Help using the Schedules Direct service. NOTE: application issues are probably better resolved via the application's support methods. If you post here, at least include your application name!
rmeden
SD Board Member
Posts: 1561
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX
Contact:

Tribune having problems, empty <PROGRAMS> section

Post by rmeden »

Tribune seems to be having problems with their server.

I've been sent some sample output from Tribune where there are <schedule> records, but the <programs> section is empty! That shouldn't happen.

XMLTV/tv_grab_na_dd 0.5.48 reports this message:
keys missing in programme hash, not writing at C:/Perl/lib/XMLTV.pm line 2572.
hash missing value for title (expected list) at C:/Perl/lib/XMLTV.pm line 2533.

MythTV seems to report "UpdateProgramViewTable no dd_state".

The problem doesn't seem to effect all lineups, so I'm not going to call the "emergency" number. I will report it and expect it will be fixed Monday.

Robert

mutterc
Posts: 1
Joined: Sat Sep 08, 2007 5:55 pm

Re: Tribune having problems, empty <PROGRAMS> section

Post by mutterc »

FYI, I just converted to SD and found the same problem with my lineups (empty <programs> section):
<lineup id='NC32421:-' name='Time Warner Cable' location='Raleigh' type='Cable' postalCode='27616'>
<lineup id='NC32421:X' name='Time Warner Cable' location='Raleigh' type='CableDigital' device='Digital' postalCode='27616'>

mistone
Posts: 2
Joined: Sat Sep 08, 2007 6:32 pm

Re: Tribune having problems, empty <PROGRAMS> section

Post by mistone »

I can confirm this...

I get this on comcast cable in berkeley.

here the xml dump : hellawack.net/zapdata.xml

I am only on the trial version, but I don't want to pay for this until its fixed...

skst
Posts: 57
Joined: Fri Aug 17, 2007 8:13 am
Contact:

Re: Tribune having problems, empty <PROGRAMS> section

Post by skst »

The problem with my lineup is that there's only one program in the programs tag.
USA-IL58819-X
WOW Chicago Suburbs - Digital
Naperville USA 60005

deastick
Posts: 3
Joined: Sun Aug 19, 2007 7:16 pm

Re: Tribune having problems, empty <PROGRAMS> section

Post by deastick »

I confirm same problem for a pull I made around noon eastern saturday. Postal code is P3E5A4 in canada.

mistone
Posts: 2
Joined: Sat Sep 08, 2007 6:32 pm

Re: Tribune having problems, empty <PROGRAMS> section

Post by mistone »

Strangely I just did a mythfilldatabase and it works... I didn't change anything.

KBevo
Posts: 4
Joined: Sun Aug 19, 2007 9:56 am

Re: Tribune having problems, empty <PROGRAMS> section

Post by KBevo »

Well at 9:45 AM (CDT), I am still getting an error from XMLTV.exe. I don't know if this is related to the same problem or not but here is the error:

WARNING: error parsing DD xml:
not well-formed (invalid token) at line 68320, column 36, byte 7472841 at /PerlApp/XML/Parser.pm line 187
ERROR: Bad XML from DD, cannot continue. Consider using --dropbadchar or Capture xml with --dd-data

Incidently, I get the same error using the --dropbadchar parm, and I already use the --dd-data parm.

Any guidance would be appreciated.

Thanks
Gary

erinbr
Posts: 2
Joined: Sun Sep 09, 2007 8:51 am

Re: Tribune having problems, empty <PROGRAMS> section

Post by erinbr »

I also am seeing the same problem as kbevo in area code 01867 on comcast standard cable:

*** Pulling listings 0 days from now, for 12 days
Fetching from Schedules Direct Fetched 9447 k/bytes in 29 seconds
loading data

WARNING: error parsing DD xml:
not well-formed (invalid token) at line 44360, column 36, byte 3557711 at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/XML/Parser.pm line 187


ERROR: Bad XML from DD, cannot continue. Consider using --dropbadchar or Capture xml with --dd-data


The funny thing is that the line (and surrounding lines) appear well-formed:

44354 </programme>
44355 <programme start="20070915120000 -0500" stop="20070915130000 -0500" channel="I10153.labs.zap2it.com">
44356 <title lang="en">The Investigators</title>
44357 <sub-title lang="en">Trail of Deceit</sub-title>
44358 <desc lang="en">A woman disappears, and her lawyer husband is found dead.</desc>
44359 <date>20041027</date>
44360 <category lang="en">Crime</category>
44361 <category lang="en">Law</category>
44362 <category lang="en">Series</category>
44363 <episode-num system="dd_progid">EP00669645.0072</episode-num>
44364 <rating system="VCHIP">
44365 <value>TV-14</value>
44366 </rating>
44367 </programme>

Not sure if that helps any..
Erin

lamonte36
Posts: 3
Joined: Fri Sep 07, 2007 12:38 pm

Re: Tribune having problems, empty <PROGRAMS> section

Post by lamonte36 »

Having same problem downloading using latest Freeguide 0.10.5 with following messages:

WARNING: error parsing DD xml:
not well-formed (invalid token) at line 66994, column 36, byte 3484646 at/PerlApp/XML/Parser.pm line 187

ERROR: Bad XML from DD, cannot continue. Consider using --dropbadchar or Capture xml with --dd-data
Message ResultCode

Will wait 'til Monday to see if it corrects.

stevech
Posts: 14
Joined: Thu Aug 16, 2007 10:51 pm

Re: Tribune having problems, empty <PROGRAMS> section

Post by stevech »

OK, we're paying now for data.

"Wait until Monday" is not adequate- my app needs one download per day.

I also use SageTV and it's EPG is working for the same cable TV provider and lineup as I have used in Schedules Direct. Same database source, I believe.

So if they can cope, why can't SD?

Post Reply