Page 1 of 1

Error on mythfilldatabase

Posted: Sat Jul 14, 2012 11:46 am
by keithc50
I am getting the following error when using mythfilldatabase on mythbuntu 0.25

content-type missing in HTTP POST, defaulting to application/octet-stream
2012-07-14 14:16:03.401980 E DataDirect: Failed to get data: Download error

Re: Error on mythfilldatabase

Posted: Fri Jun 20, 2014 12:17 pm
by chucklebutty
I am consistently getting the same error with 0.27, to the point that there is no program data for the backend and recording has stopped.

I tried some suggestions from the similar thread from March but got no relief. Are you still seeing the issue? If not did you do anything that might have fixed it?


Re: Error on mythfilldatabase

Posted: Mon Jun 23, 2014 8:30 am
by rkulagow
There were a number of errors in MythTV 0.27 related to Schedules Direct.

You should upgrade to at least 0.27.1.

Re: Error on mythfilldatabase

Posted: Mon Jun 23, 2014 5:14 pm
by chucklebutty
My intent here was to see if the other person reporting the error found relief. My information provided to to the support page states that I did in fact take the latest update available from mythbuntu and it made no difference. This was working for weeks and stopped with no config change I'm aware of on the same day as the OP.

For reference, the version that is installed that I can confirm is still getting no data is:

$ mythfilldatabase --version
Please attach all output as a file in bug reports.
MythTV Version : v0.27.1-16-gaa822f5
MythTV Branch : fixes/0.27
Network Protocol : 77
Library API : 0.27.20140520-1
QT Version : 4.8.1

Which I believe _is_ 0.27-1. The first overt error seems to be:

2014-06-23 13:46:58.830356 D downloadFinished(24939280): COMPLETE: http://webservices.schedulesdirect.tmsd ... tvdService
2014-06-23 13:47:58.925384 D DownloadManager: Aborting download - lack of data transfer
2014-06-23 13:47:58.925530 E DataDirect: Failed to get data: Download error

when verbose is all and loglevel is debug.