Channel icons unavailable

Post Reply
sihy
Posts: 3
Joined: Mon Apr 20, 2020 6:16 am

Channel icons unavailable

Post by sihy »

At the risk of this thread getting locked/becoming irrelevant due to the time lag between me submitting the post and it being accepted ;)

Although the EPG data is now coming through (woohoo), unfortunately the channel icons seem to be unavailable (boohoo).

TVHeadend reports for example:
failed to download https://schedulesdirect-api20141201.s3. ... _h3_ab.png

Trying to visit the icon in a browser yields:
' cannot be displayed, because it contains errors.'

Probably user error etc., if anyone has any suggestions they're appreciated.

Cheers,
Simon

rkulagow
SD Staff
Posts: 933
Joined: Tue Aug 14, 2007 3:15 pm

Re: Channel icons unavailable

Post by rkulagow »

Please open a support ticket on the Schedules Direct website and I will investigate.

sihy
Posts: 3
Joined: Mon Apr 20, 2020 6:16 am

Re: Channel icons unavailable

Post by sihy »

The URL seems to work now in a web browser so all's well. Not appearing yet in TVHeadend yet but I'm sure a cache refresh etc will get it back to normal now the URLs are back up.

Thanks,
Simon

edit: yep, back on TVH now.

pete318
Posts: 10
Joined: Wed Nov 23, 2016 6:30 pm

Re: Channel icons unavailable

Post by pete318 »

I'm also getting 403 on all icons so far as I can see. Only noticed now, since I periodically refresh them, and today was the day!

I tried popping in a valid SD token, just in case it was needed. But, to no avail.

EDIT: Actually, ignore me. It looks like my software wasn't updating the icon in the xmltv when it changed on SD. I'll change it to overwrite it. I still had links with s3.amazonaws.com and not the news ones.

Post Reply