station ID 21868 Showtime HD no data after 2015-10-04T15:00Z

Post Reply
jagsd
Posts: 42
Joined: Sun Sep 09, 2007 10:52 am

station ID 21868 Showtime HD no data after 2015-10-04T15:00Z

Post by jagsd » Wed Sep 23, 2015 3:47 pm

Is something wrong with Station ID 21868 Showtime HD?

There is no new program data after 2015-10-04T15:00:00Z. All of my other stations have program info up to about 2015-10-14, 10 more days.

Note that /schedules returns dates out to 2015-10-14 but the programs arrays are empty.

rkulagow
SD Staff
Posts: 915
Joined: Tue Aug 14, 2007 3:15 pm

Re: station ID 21868 Showtime HD no data after 2015-10-04T15

Post by rkulagow » Wed Sep 23, 2015 5:51 pm

I'm seeing the same on the server; I have a bulk load running now so lets see if it's still happening once it's complete.

jagsd
Posts: 42
Joined: Sun Sep 09, 2007 10:52 am

Re: station ID 21868 Showtime HD no data after 2015-10-04T15

Post by jagsd » Thu Sep 24, 2015 8:23 am

rkulagow wrote:I'm seeing the same on the server; I have a bulk load running now so lets see if it's still happening once it's complete.
FYI, this did not fix the problem. Programs still missing.

rkulagow
SD Staff
Posts: 915
Joined: Tue Aug 14, 2007 3:15 pm

Re: station ID 21868 Showtime HD no data after 2015-10-04T15

Post by rkulagow » Thu Sep 24, 2015 8:36 am

Yes, I'm stepping through the code now to see where it's doing the wrong thing.

rkulagow
SD Staff
Posts: 915
Joined: Tue Aug 14, 2007 3:15 pm

Re: station ID 21868 Showtime HD no data after 2015-10-04T15

Post by rkulagow » Thu Sep 24, 2015 9:08 am

OK, found it. There's bad upstream data that was causing my code to do the wrong thing. It now handles the error better and allows schedules that are valid to be built. The update is running now.

rkulagow
SD Staff
Posts: 915
Joined: Tue Aug 14, 2007 3:15 pm

Re: station ID 21868 Showtime HD no data after 2015-10-04T15

Post by rkulagow » Thu Sep 24, 2015 10:18 am

Can you check now?

jagsd
Posts: 42
Joined: Sun Sep 09, 2007 10:52 am

Re: station ID 21868 Showtime HD no data after 2015-10-04T15

Post by jagsd » Thu Sep 24, 2015 12:05 pm

rkulagow wrote:Can you check now?
Looks good now. Thanks.

Post Reply