Schedule times wrong after daylight savings time change

Forum rules
Get Help using the Schedules Direct service. NOTE: application issues are probably better resolved via the application's support methods. If you post here, at least include your application name!
Post Reply
carlhage
Posts: 1
Joined: Sun Mar 10, 2013 5:38 pm

Schedule times wrong after daylight savings time change

Post by carlhage » Sun Mar 10, 2013 6:29 pm

I noticed that my mythtv schedule listings were wrong yesterday when looking at todays (new daylight savings time). The listings correctly showed a jump from 1am to 3am, but then the next days listings were off by 1 hour (they were 1 hour earlier, as if DST correction happened twice). I noticed that some channels were corrected, but could have been EIT overwrite for what I was watching.

Is there a way to not have a major disruption in the future for each time zone change? Seems like people go through extreme grief every 6 months.

I fumbled around with manual commands, finally trying "sudo mythfilldatabase --refresh 0" that finally seemed to replace the data. What is the best way to refresh bad listing data with the correct stuff?

rmeden
SD Board Member
Posts: 1521
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX
Contact:

Re: Schedule times wrong after daylight savings time change

Post by rmeden » Sun Mar 10, 2013 10:18 pm

We provide the data in UTC and since very few people have DST issues, it is probably a local problem on your end.

If you use tv_grab_na_dd, it takes a "time offset" to make things more readable, and reports the time in "yyyy-mm-ddThh:mm:ss -tttt" format. (where tttt is the time offset). If your app only looks at hh:mm and doesn't take tttt into account, that can cause the symptoms you're seeing.

I suggest you view some raw data at http://schedulesdirect.org/getdata convert from UTC to local time yourself to determine if something is wrong with the data (it does happen sometimes).

If something is wrong with the data, submit a lineup report with specific examples and we'll get it fixed. Usually it's a local config problem though.

Robert

Post Reply