ddClient

Discussion about Schedules Direct grabber code and data formats.

ddClient

Postby rshendershot » Wed Aug 22, 2007 3:56 am

Will Schedules Direct be replacing or supporting the poc web services application that TMS provides in their ddClient.zip ?

TMS' 1.3.2 release seems not to support java 1.6.
rshendershot
 
Posts: 51
Joined: Fri Aug 17, 2007 6:19 am

Re: ddClient

Postby danielk » Wed Aug 22, 2007 6:55 am

Code: Select all
Will Schedules Direct be replacing or supporting the poc web services application that TMS provides in their ddClient.zip ?


No, but TMS will probably continue to support the client for their commercial customers as DataDirect is continuing, just not Labs. Our service may not work with their example programs in a few months time as we continue to enhance the Schedules Direct service.
danielk
SD Board Member
 
Posts: 62
Joined: Tue Aug 14, 2007 2:40 pm

Re: ddClient

Postby rpaxton » Mon Aug 27, 2007 6:31 pm

I just downloaded the 1.3.7 xsd from zap2it. I use ddclient 1.3.2. The 1.3.7 xsd has a couple of attributes not in the 1.3.2 client, such as the "new" attribute of the xsd. Does Schedules Direct follow the 1.3.7 xsd. If not is there a xsd published anywhere for the Schedules Direct xml file?
rpaxton
 
Posts: 8
Joined: Wed Aug 22, 2007 5:26 pm

Re: ddClient

Postby rmeden » Mon Aug 27, 2007 10:40 pm

Last I heard 1.3.7 wasn't released to the public yet. We've been talking with TMS asking them to release it.

Yes the SD data confirms to 1.3.7 (I got my copy under NDA)
rmeden
SD Board Member
 
Posts: 1513
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Re: ddClient

Postby rpaxton » Tue Aug 28, 2007 4:02 pm

rmeden wrote:Last I heard 1.3.7 wasn't released to the public yet. We've been talking with TMS asking them to release it.

Yes the SD data confirms to 1.3.7 (I got my copy under NDA)



I found the url to it the ddclient source code as part of a namespace variable and just pointed my browser to it.
After taking a closer look it may not be 1.3.7. I found one place that has a v 1.37 but the schemaVersion attribute has just 1.3, so I may be wrong about the version.
rpaxton
 
Posts: 8
Joined: Wed Aug 22, 2007 5:26 pm


Return to Developers Corner

Who is online

Users browsing this forum: No registered users and 4 guests

cron