Show Not showing up properly as new

Use this forum to report problems with lineups

Show Not showing up properly as new

Postby TechRavingMad » Sat Aug 15, 2009 12:39 pm

I've come across shows that are not showing up as "New".

An example:

I ran tv_grab_na_dd and redirected output to file.xml. (running via command line on an ubuntu linux box)

<programme start="20090818190000 -0600" stop="20090818210000 -0600" channel="I34885.labs.zap2it.com">
<title lang="en">America's Got Talent</title>
<desc lang="en">Ten more acts from the top 40 perform.</desc>
<credits>
<presenter>Nick Cannon</presenter>
</credits>
<date>20090818</date>
<category lang="en">Reality</category>
<category lang="en">Music</category>
<category lang="en">Series</category>
<episode-num system="dd_progid">EP00829878.0067</episode-num>
<episode-num system="onscreen">417</episode-num>
<video>
<aspect>16:9</aspect>
<quality>HDTV</quality>
</video>
<audio>
<stereo>dolby</stereo>
</audio>
<previously-shown start="20090818000000" />
<subtitles type="teletext" />
<rating system="VCHIP">
<value>TV-PG</value>
</rating>
</programme>

That is what is shown inside the file for a new show. The above listed show is the first ever airing of that show. I've tried filtering manually in several ways, but I can't come up with a 100% accurate way to filter out only "new" shows when items like the above occur. I can't simply use "tv_grab_na_dd | tv_grep with --not --previously-shown" cause the above example wouldn't show, using "tv_grab_na_dd | tv_grep --new" returns NO shows, just a channel list. Likewise I can't do a manual filter based off of <programme start="20090818190000 and <previously-shown start="20090818000000" /> because 1) They don't match and 2) if I only exclude based off the date only and not the time then I'll catch same-day re-runs that often occur on History and SyFy.

Is this a bug in the tv_grab_na_dd or is there a reliable way to get only new, first run shows, or is it a problem in the tv lineup? I'm not sure this is a lineup issue or a bug, if it's a bug I apologize for putting in the wrong forum, please move to the appropriate place.

Thanks,
TechRavingMad
 
Posts: 3
Joined: Thu Aug 13, 2009 8:44 pm

Re: Show Not showing up properly as new

Postby rmeden » Sun Aug 16, 2009 12:06 am

First, start with notes on "new" vs "repeat" from the developer section to understand what the original data says.


Second, how old is the version of tv_grab_na_dd you're using? The current version (1.76 in XMLTV 0.5.56) removes any "previously-shown" attribute if Tribune flags an episode as new. I just scanned the commit log for _na_dd and I don't see any major changes in that code since 2007. Is your version that old? The XML sample you provided has "previously-shown"=="today".

Third, applications may choose what "previously-shown" dates to consider new. For example, in tv_check, I consider a "previously-shown" in the past week as "new".

Forth, tv_grep may need some tweaks ( but I think with the latest _na_dd it will work fine)

Robert
rmeden
SD Board Member
 
Posts: 1516
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Re: Show Not showing up properly as new

Postby TechRavingMad » Sun Aug 16, 2009 2:51 pm

Thanks for the reply, I've been frustrated by this for a while and finally decided to post.

1) Read the "new" vs "repeat" thread, several times, I assumed it would solve my problem but it doesn't. It was actually what lead me to post it into lineup issues.

2) Brand new:
XMLTV module version 0.5.56
This is tv_grab_na_dd.in version 1.76, 2009/07/28 04:47:22

I downloaded the raw Tribune data (relevant sections):
Code: Select all
     <program id='EP008298780067'>
     <title>America&apos;s Got Talent</title>
     <description>Ten more acts from the top 40 perform.</description>
     <showType>Series</showType>
     <series>EP00829878</series>
     <syndicatedEpisodeNumber>417</syndicatedEpisodeNumber>
     <originalAirDate>2009-08-18</originalAirDate>
     </program>

     <schedule program='EP008298780067' station='34885' time='2009-08-19T01:00:00Z' duration='PT02H00M' tvRating='TV-PG' stereo='true' hdtv='true' closeCaptioned='true' dolby='Dolby'/>


You can see that it doesn't flag it as "new='true'", but then again it looks like the Tribune data only flags SH episodes as new and never EP episodes.

3) Understood that applications ultimately make the decision, that's great, and I don't mind having to write my own application/script if I can figure out how to solve the problem of 100% no-repeats with the data.

No reply needed on #4, I still think this may be a lineup issue.
TechRavingMad
 
Posts: 3
Joined: Thu Aug 13, 2009 8:44 pm

Re: Show Not showing up properly as new

Postby rmeden » Sun Aug 16, 2009 6:46 pm

new="true" is in the <schedule> section. A show is only flagged "new" if it's truly the first time it aired. If an episode is on at 8pm and 10pm, only the 8pm has the "new" flag. Personally, I consider both episodes "new", that's why I recommend applications use their own definition of "new" and the previously-shown value.

In your example, I suspect it had a "new=true" on 8/18.

SH* episodes are seldom "new". In most cases SH* means that detailed information isn't available.

Robert
rmeden
SD Board Member
 
Posts: 1516
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Re: Show Not showing up properly as new

Postby rmeden » Sun Aug 16, 2009 7:15 pm

I've looked into this a little more... and you're right... There appears to be problems with "America's Got Talent". It's really confusing.. it's almost like there are two sequences of episode numbers, but only one gets the "new" flag.

I'll check with RobertK to see if he's already reported it (he usually does this thing), if not I'll report it.

If you use the episode number to determine unique episodes you'll be ok.

Robert
rmeden
SD Board Member
 
Posts: 1516
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Re: Show Not showing up properly as new

Postby TechRavingMad » Mon Aug 17, 2009 8:14 pm

Thanks again for looking into it.
TechRavingMad
 
Posts: 3
Joined: Thu Aug 13, 2009 8:44 pm


Return to Lineup Issues

Who is online

Users browsing this forum: No registered users and 4 guests

cron