Page 1 of 1

My subscribed channels keep changing

PostPosted: Thu Dec 15, 2016 6:40 pm
by rhywun
This has been happening for years but today it's worse than usual. I went to edit my subscription and found dozens of subscribed channels I never chose. Why does this keep happening? (My client - FreeGuide - allows me to filter the channels so I didn't notice it until I wanted to add a new channel.)

Re: My subscribed channels keep changing

PostPosted: Fri Dec 16, 2016 9:01 am
by rmeden
I think you're using the SD-DD service....

The SD-DD service (and Gracenote's Data Direct service before it) always auto-added new stations. I seem to recall Gracenote's service also had some bugs where you could get stations that no longer existed. (they wouldn't be removed from your lineup when they went away.)

For SD-DD, I only store stations you manually exclude. So new stations automatically show up when they are in the upstream lineup.

This is how it's always been, but some application or grabbers allow you to ignore new stations. I know tv_grab_na_dd and MythTV can do it. I'm not familiar with how Freeguide gets the data.

If you're seeing lots of new stations, it usually means your cable company may be in the middle of a shuffle.

Robert

Re: My subscribed channels keep changing

PostPosted: Fri Dec 16, 2016 12:47 pm
by rhywun
I suspected something like that. Especially since TWC is now "Spectrum"... and I see another dozen were added just today.

FreeGuide uses tv_grab_na_dd and there is a box where I can set the command-line. After some research I think I can add an ignore option to stop this. I hope it works.

Re: My subscribed channels keep changing

PostPosted: Sat Dec 17, 2016 1:06 am
by rmeden
I think the option is "--auto-conifg ignore" Also check the tv_grab_na_dd config file, the default option may be there. (It's been years since I wrote it)

Re: My subscribed channels keep changing

PostPosted: Sat Dec 17, 2016 7:55 am
by rhywun
rmeden wrote:I think the option is "--auto-conifg ignore" Also check the tv_grab_na_dd config file, the default option may be there. (It's been years since I wrote it)


Yep, the default option was "--auto-config add" and I changed it to "ignore".