401 Unauthorized problem

Forum rules
Get Help using the Schedules Direct service. NOTE: application issues are probably better resolved via the application's support methods. If you post here, at least include your application name!

401 Unauthorized problem

Postby Syztemlord » Tue Mar 24, 2015 4:53 am

Hi,

I'm quite new to Schedules Direct and just working my way round everything. I'm trying to use WebGrab to download my listings but I keep getting the "401 Unauthorized" error. I've used another app called Freeguide and that downloads my selected listings ok so I know my account is working.

I'd really like to use WebGrab, any ideas on what is going wrong?
Syztemlord
 
Posts: 1
Joined: Tue Mar 24, 2015 1:48 am

Re: 401 Unauthorized problem

Postby rmeden » Tue Mar 24, 2015 1:48 pm

Have you checked with the webguide folks? Did they update their app to deal with the server changes late last year?
rmeden
SD Board Member
 
Posts: 1511
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Re: 401 Unauthorized problem

Postby caesarscook » Sat Sep 05, 2015 4:36 pm

I'm receiving this error also after switching from mc2xml to WebGrabPlus. Here's the debug log output from WG:

[ Debug ] WebGrab+Plus/w MDB & REX Postprocess -- version 1.1.1/55.26 -- Jan van Straaten
[ Debug ] --------------------------------------------------------------------------------
[ Debug ] job started at 9/5/2015 3:40:08 PM
[ Debug ]
[ Debug ] reading config file: C:\ProgramData\ServerCare\WebGrab\WebGrab++.config.xml
[ Debug ] loading timezone data
[ Debug ] embedded timezones source: WGconsole.WG.Common.TimezonesData.txt
[ Debug ] found: C:\ProgramData\ServerCare\WebGrab\schedulesdirect.org.ini -- Revision 1
[ Debug ]
[ Debug ] running on: Microsoft Windows NT 6.2.9200.0
[ Debug ] environment: 4.0.30319.42000
[ Debug ] xmltv input file - C:\ProgramData\ServerCare\WebGrab\guide.xml - found
[ Debug ] 0 superfluous shows removed
[ Info ]
[ Info ] update requested for - 1 - out of - 1 - channels for 1 day(s)
[ Info ] update mode - set per individual channel
[ Info ]
[ Info ]
[ Info ] i=index .=same c=change g=gab r=replace n=new
[ Info ]
[ Debug ]
[ Info ] channel (xmltv_id=dummy) site -- SCHEDULESDIRECT.ORG -- mode full
[ Warn ] error downloading page: The remote server returned an error: (401) Unauthorized.
[ Warn ] pausing 1 of 4 times for 5 seconds before re-try.
[ Warn ] error downloading page: The remote server returned an error: (401) Unauthorized.
[ Warn ] pausing 2 of 4 times for 10 seconds before re-try.
[ Warn ] error downloading page: The remote server returned an error: (401) Unauthorized.
[ Warn ] pausing 3 of 4 times for 15 seconds before re-try.
[ Warn ] error downloading page: The remote server returned an error: (401) Unauthorized.
[ Warn ] pausing 4 of 4 times for 20 seconds before re-try.
[ Error ] no index page data received from dummy
[ Error ] unable to update channel, try again later
[ Info ] existing guide data restored!
[ Debug ]
[ Debug ] 0 shows in 1 channels
[ Debug ] 0 updated shows
[ Debug ] 0 new shows added
[ Info ]
[ Info ]
[ Info ] job finished at 9/5/2015 3:40:59 PM done in 51 seconds
[ Debug ] statistics upload error: The remote server returned an error: (500) Internal Server Error.


I have used WG before and my configurations are correct. In the schedulesdirect.org.ini file, my authentication details are entered correctly. I cannot event get the dummy channels to give me my channel list. I can log into my account on the SD website, I can get data from http://schedulesdirect.org/getdata, and my subscription is up to date. I also just ran mc2xml and got data from SD properly with it. I would really like to switch over to WebGrabPlus though. What am I doing wrong?
caesarscook
 
Posts: 4
Joined: Sat Sep 05, 2015 3:39 pm

Re: 401 Unauthorized problem

Postby rmeden » Sat Sep 05, 2015 8:47 pm

Same response to the previous poster... has webguide been updated to use the new server?

Quickeest test is via XMLTV.

Assuming you're on windows.. http://alpha-exe.xmltv.org (save it somewhere)

CD to that directory from a command prompt
xmltv.exe tv_grab_na_dd --configure # answer questions
xmltv.exe tv_grab_na_dd --days 1 --output tv.xml # will output 1 day in XMLTV format to tv.xml
rmeden
SD Board Member
 
Posts: 1511
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Re: 401 Unauthorized problem

Postby caesarscook » Sat Sep 05, 2015 10:54 pm

Followed instructions. Got this output:

Microsoft Windows [Version 10.0.10240]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\Users\USERNAME>cd C:\Users\jrluc_000\Downloads

C:\Users\USERNAME\Downloads>xmltv.exe tv_grab_na_dd
Timezone is -0500
directory C:/Users/USERNAME/Downloads/share/xmltv not found
If not kept with the executable, specify with --share


So, no configuration could take place. In answer to your other question, according to the WebGrabPlus forums, yes, they have produced an updated ini file for schedulesdirect.org following SD's site updates last year. Other people seem to be using WGP with SD without issue. Not sure what my problem is, but I'd very much like to use WGP as my grabber if at all possible.

EDIT: Here's a snippet from the schedulesdirect.org.ini file from WGP:

* @header_start
* WebGrab+Plus ini for grabbing EPG data from TvGuide websites
* @Site: schedulesdirect.org
* @MinSWversion: V1.1.1/54
* @Revision 1 - [23/10/2014] Jan van Straaten
* - adapted site changes
* @Revision 0 - [31/08/2013] Jan van Straaten / Francis De Paemeleere
* - creation
* @Remarks: You need a login and password for this site
* @header_end


I believe the "Revision 1" changes are specifically geared towards the SD site changes, as this line from the same ini file would seem to suggest:

url_index {url|http://dd.schedulesdirect.org/schedulesdirect/tvlistings/xtvdService}
caesarscook
 
Posts: 4
Joined: Sat Sep 05, 2015 3:39 pm

Re: 401 Unauthorized problem

Postby rmeden » Sat Sep 05, 2015 11:43 pm

add --share=. to the command , so xmltv tv_grab_na_dd --share=. --configure
rmeden
SD Board Member
 
Posts: 1511
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Re: 401 Unauthorized problem

Postby caesarscook » Sun Sep 06, 2015 10:04 am

That worked. But I'm still getting nothing from WGP. The grab continues to fail with a 401 unauthorized error.
caesarscook
 
Posts: 4
Joined: Sat Sep 05, 2015 3:39 pm

Re: 401 Unauthorized problem

Postby rmeden » Sun Sep 06, 2015 5:28 pm

So it must be a WGP problem..

Maybe they didn't update their app for the new hostname. Read the sticky "Schedules Direct migration to self-hosting" and try the hosts file hack.
rmeden
SD Board Member
 
Posts: 1511
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Re: 401 Unauthorized problem

Postby caesarscook » Mon Sep 07, 2015 11:38 am

As stated above, their program is most definitely updated to the new SD site name. That wasn't the problem. I did resolve the problem myself though, as the WGP forum wasn't that helpful. For anyone else having this issue, you probably need to make sure that the authentication line in the site ini file for schedulesdirect.org isn't commented out, i.e. remove the "*" at the start of the line with you password and username. I can't believe I didn't notice that it was commented out to begin with, although why it would be in the first place is really hard for me to figure out. (Why would you run a grab of SD without entering authentication info? It wouldn't return anything?!) Anyway, problem solved, although the SD grab is significantly slower than from other sources using WGP (exponentially slower). I'm not sure what the reason is for that.
caesarscook
 
Posts: 4
Joined: Sat Sep 05, 2015 3:39 pm

Re: 401 Unauthorized problem

Postby rmeden » Mon Sep 07, 2015 1:52 pm

You can determine if it's a WGP problem by timing tv_grab_na_dd... add the --download-only switch to exclude the conversion time to XMLTV.

You can also probably speed it up by removing stations you don't care about by editing the lineup on the SD web site.

Robert
rmeden
SD Board Member
 
Posts: 1511
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX


Return to Support

Who is online

Users browsing this forum: No registered users and 6 guests