DataDirect replacement service going live!

Forum rules
Get Help using the Schedules Direct service. NOTE: application issues are probably better resolved via the application's support methods. If you post here, at least include your application name!
rmeden
SD Board Member
Posts: 1526
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX
Contact:

Re: DataDirect replacement service going live!

Post by rmeden » Fri Oct 17, 2014 3:03 pm

No, having two lines doesn't hurt, but you should be able to have multiple hostnames separated by a space.

rmeden
SD Board Member
Posts: 1526
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX
Contact:

Re: DataDirect replacement service going live!

Post by rmeden » Fri Oct 17, 2014 3:16 pm

ajlill wrote:My account is ajlill@ajlc.xxxxx and it doesn't expire till next june.
The problem started a 5am EST today, and was a connect to the replacement IP. My previous attempt was at 10am EST yesterday, so I doubt I was banned for excessive connections!
Sorry, I didn't mean to imply you were banned. I just posted to let folks know something I updated in the parent post.

Can you log on to the SD website? If not, reset your password. If you can, confirm in your MythTV setup your username and password are correct. I'm sure you run into this all the time, but it's very hard to read your username on a screen with all the l's i's and j's :)

BTW, sd-dd (and sd-json) go to schedulesdirect.org for authentication... there is no way it can get out of sync like the TMS servers have.

Robert

jrguy
Posts: 1
Joined: Fri Oct 17, 2014 5:05 pm

Re: DataDirect replacement service going live!

Post by jrguy » Fri Oct 17, 2014 5:26 pm

I use SD for the My Telly app which has not been maintained by developers for several years. Coding 54.85.117.227 into the two-line hosts file format presented by skst resulted in the following message when attempting a Guide update:

"Error Making Server Request

Getting data..
com.withay.http.BadAuthorizationException
2014-10-14T00:41:05Z Opening connection to <http://webservices.schedulesdirect.tmsd ... tvdService>
2014-10-17T00:41:05Z Sending first request for digest nonce"

Substituting 144.142.232.53 in both lines worked and produced an updated Guide. My SD username is jole60 and the account expires in June 2015.

RonF
Posts: 4
Joined: Mon Aug 20, 2007 8:58 pm

Re: DataDirect replacement service going live!

Post by RonF » Fri Oct 17, 2014 5:55 pm

I ran into authentication problems here too. I tracked it down to the fact that the new server supports only HTTP basic auth, whereas my client was hardcoded to use HTTP digest auth, which was supported by the old server. After switching to basic auth, the download worked fine.

rmeden
SD Board Member
Posts: 1526
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX
Contact:

Re: DataDirect replacement service going live!

Post by rmeden » Fri Oct 17, 2014 7:26 pm

jrguy wrote: com.withay.http.BadAuthorizationException
2014-10-14T00:41:05Z Opening connection to <http://webservices.schedulesdirect.tmsd ... tvdService>
2014-10-17T00:41:05Z Sending first request for digest nonce"
RonF is right, the new server only supports BASIC not digest authentication. I need to keep it that way until Nov 1 in order to get lineups from TMS-DD.

I'll add a known issue.

Robert

ajlill
Posts: 9
Joined: Thu Sep 13, 2007 1:40 pm

Re: DataDirect replacement service going live!

Post by ajlill » Sat Oct 18, 2014 9:03 am

I tracked down my problem to my squid cache. I don't know why, but the DNS trickery must have bolloxed up authentication through the cache. Once I turned off tranparent proxying, downloads worked.

howmanytimes
Posts: 1
Joined: Sat Oct 18, 2014 1:27 am

Re: DataDirect replacement service going live!

Post by howmanytimes » Sat Oct 18, 2014 9:55 am

Could this be the same thing that is happening with MC2XML v1.2? It crashes at the user authentication stage whenever the HOSTS file has the above IP address redirect in place. When I REM it out, it works fine again.

Also I have been testing the Schedules Direct XMLTV program with the "tv_grab_na_dd" subroutine to move forward, and it looks promising. I collect movies, so I have really only been paying attention to movie information. Overall things are looking good to me, except for the "star-rating" value, which seems to show 1 star for every single movie (this may not be new, but I just noticed it last night). I am getting this 1-star-rating issue whenever I use the HOSTS file IP address redirect. When I REM it out, the star-rating system becomes populated with correct values again.

rmeden
SD Board Member
Posts: 1526
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX
Contact:

Re: DataDirect replacement service going live!

Post by rmeden » Sat Oct 18, 2014 1:55 pm

Don't know about mc2xml, but I wrote tv_grab_na_dd ages ago and it was (and still is) my primary test case. :)

The star-ratings bug was reported today in another thread and has been fixed.

BTW, the latest tv_grab_na_dd version ( http://alpha-exe.xmltv.org if on windows) only uses sd-dd and doesn't need a host file change.

Robert

howmanytimes
Posts: 1
Joined: Sat Oct 18, 2014 1:27 am

Re: DataDirect replacement service going live!

Post by howmanytimes » Sat Oct 18, 2014 2:18 pm

Sounds Great! Thanks for everything.
Chris

pgbennett
Posts: 10
Joined: Sat Sep 27, 2014 2:03 pm

Re: DataDirect replacement service going live!

Post by pgbennett » Sun Oct 19, 2014 7:35 am

Missing a day and a half of data
I upgraded my mythtv to 0.27.4 yesterday and so mythfilldatabase used the new URL today (October 19)
I get two weeks of schedule, but a day and a half is missing.
Mythfilldatabase reports " Grab complete. Actual data from 2014-10-18T09:07:36Z to 2014-11-02T09:07:36Z (UTC)"
I see schedules from now to 8 PM Friday October 31 and Sunday Nov 2 4:30 AM to Sunday Nov 2 7 PM
The period from 8 PM Oct31 to 4:30 AM Nov 2 shows "No Data".
Somebody reported a similar issue in the mythtv users mailing list, but he reported missing data for October 26 to October 27.
There is no error message in the mythfilldatabase log to indicate why that day and a half are missing.
Perhaps the data that I see for Sun Nov 2nd is from the prior run of mythfilldatabase that used the old schedules direct and the new one only gives data until 8PM Oct 31? Although then it should not say in the log that there is data until 2014-11-02T09:07:36Z (UTC) when there is actually only data until 2014-10-31.

Peter

Post Reply