Web says member until 2013, but Myth thinks 2012

Forum rules
Get Help using the Schedules Direct service. NOTE: application issues are probably better resolved via the application's support methods. If you post here, at least include your application name!

Web says member until 2013, but Myth thinks 2012

Postby dillowda » Fri Jun 08, 2012 2:36 pm

I signed up on June 2nd, and paid for my first year of service on June 6th. My expiration date is listed on the website as June 9th, 2013, but MythTV (0.25) thinks my account expires tomorrow:

2012-06-08 17:33:37.530105 W DataDirect: WARNING: Your subscription expires on Sat Jun 9 2012 3:38 AM

When I first signed up, I got the notice that my account was affected by a random bug and would take about an hour to activate; is this a related problem?
I've also tried resetting my password as was mentioned in another thread, and adding a new lineup also does not show up in MythTV when I add a new video source.

What should I do next? My username is dillowda.

Thanks!
dillowda
 
Posts: 3
Joined: Fri Jun 08, 2012 2:28 pm

Re: Web says member until 2013, but Myth thinks 2012

Postby rmeden » Sat Jun 09, 2012 12:15 am

Hmmmm that's strange... I show everything looks good on our side. Is it working better today? Maybe it took longer than normal to propagate to the data servers.

Robert
rmeden
SD Board Member
 
Posts: 1513
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Re: Web says member until 2013, but Myth thinks 2012

Postby dillowda » Sat Jun 09, 2012 8:38 am

Looking through the Myth code while waiting for the topic to be approved, I'm not entirely convinced this isn't a cosmetic bug on Myth's side. I'll look a little deeper and let you know what I find.
dillowda
 
Posts: 3
Joined: Fri Jun 08, 2012 2:28 pm

Re: Web says member until 2013, but Myth thinks 2012

Postby dillowda » Sat Jun 09, 2012 9:25 am

Ok, not a cosmetic bug, just operator error and Myth leaving a temporary file sitting around after completing the load. I had first run things as root, and then changed to running as a normal user. mythfilldatabase leaves /tmp/myth_ddp_data sitting around, so it was owned by root. Running as the normal user, it was properly downloading the correct data, failing to write it to the temp file, then reading the stale data from that file.

So, fixed by removing the root-owned file, and all is well now.

Sorry for the false alarm...
dillowda
 
Posts: 3
Joined: Fri Jun 08, 2012 2:28 pm


Return to Support

Who is online

Users browsing this forum: No registered users and 10 guests

cron