2010-07-13 outage *RESOLVED*

2010-07-13 outage *RESOLVED*

Postby rmeden » Tue Jul 13, 2010 9:55 am

I have detected problems on Tribune's authentication server which effects account and lineup changes. There was a software updated scheduled to occur about this time and it may be related.

To prevent data sync issues, I have disabled the SD web app while it gets sorted out.

Data downloads should still work.

I'll post updated status when I have some.

Robert
rmeden
SD Board Member
 
Posts: 1478
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Re: 2010-07-13 outage

Postby rmeden » Tue Jul 13, 2010 3:21 pm

I'm still working with Tribune on this.

The problem is with adjusting expiration dates. Other things seem to work.

I'm keeping the web app down because I can see this causing *LOTS* of issues.

We'll see how things go.

Robert
rmeden
SD Board Member
 
Posts: 1478
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Re: 2010-07-13 outage

Postby slatulippe » Tue Jul 13, 2010 3:35 pm

Hi,

Starting today, I am having a small download issue. Using these boundaries:

my $START="$ARGV[0]T04:00:00Z";
my $STOP ="$ARGV[1]T03:59:59Z";

it now downloads a show that ends at T04:00:00Z, while until yesterday, it only returned shows starting before T04:00:00Z only if they ended later than T04:00:00Z. Now, a show that starts at say, T03:30:00Z and ends at T04:00:00Z gets returned.

I had to change my start to this in order to try to obtain the same result as before: (notice the second)

my $START="$ARGV[0]T04:00:01Z";

I think it may be related to the problem you have also since today. This smells like a software update somewhere....

slatulippe
slatulippe
 

Re: 2010-07-13 outage

Postby rmeden » Tue Jul 13, 2010 4:44 pm

Tribune doesn't expect a solution today.

I've disabled many function on our web page to prevent confusion. Data downloads should continue to work.

slatulippe: I thought that's the way it worked before. I remember adding the one-second trick to tv_grab_na_dd.

I'll report it. (maybe it used to do it, stopped and now does it again)

Robert
rmeden
SD Board Member
 
Posts: 1478
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Re: 2010-07-13 outage

Postby slatulippe » Tue Jul 13, 2010 5:01 pm

Hi Robert,

I have been using your service for 1.5 years. I had changed nothing since the beginning, and my homemade parsing tool failed for the first time and it seems to be related to that.

I think I am okay with the one-second trick, I'd appreciate if you have any confirmation from Tribune about any change, nonetheless.

Thanks,
slatulippe
slatulippe
 

Re: 2010-07-13 outage

Postby doomed999 » Wed Jul 14, 2010 12:16 am

Just curious. as I am new here. Would this be causing the following error? You mention that the data downloads shouldn't be affected, but I can't get any data.

Thanks!


2010-07-14 01:34:16.707012 [SchedulesDirect EPG Client(5)]: Requesting 24 hours of program listings from [7/14/2010 1:34:16 AM] to [7/15/2010 1:34:16 AM]
2010-07-14 01:34:19.927196 [SchedulesDirect EPG Client(5)]: System.Net.WebException: The request failed with HTTP status 505: HTTP Version Not Supported.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at SchedulesDirect.SchedulesDirectWebService.SchedulesDirectWebServiceProxy.download(String startTime, String endTime)
at SchedulesDirect.SchedulesDirectWebService.Download(DateTime startTime, DateTime endTime)
at SchedulesDirect.Plugin.SchedulesDirectPluginTVE3.RunEpgImport()
2010-07-14 01:34:19.928196 [SchedulesDirect EPG Client(5)]: ProtocolError
2010-07-14 01:34:19.931197 [SchedulesDirect EPG Client(5)]: HttpVersionNotSupported
doomed999
 
Posts: 1
Joined: Wed Jul 14, 2010 12:08 am

Re: 2010-07-13 outage

Postby RVCA18 » Wed Jul 14, 2010 7:27 am

Any idea when the account payments service will be back online? I was going to pay for the year since my trial was up and now I can't. All my scheduled programs are going berserk :(
RVCA18
 

Re: 2010-07-13 outage

Postby rmeden » Wed Jul 14, 2010 8:19 am

The problem has been fixed.

Tribune required a part of the API that was previously optional (and we weren't using).

Hopefully this new version will fix a lot of issues and this was the only breakage. :)

Robert
rmeden
SD Board Member
 
Posts: 1478
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Re: 2010-07-13 outage *RESOLVED*

Postby harolds » Wed Jul 14, 2010 11:44 am

Ever since yesterday (7/13) using xtvdWebService.cs from the development section I get the below error when calling Download("2010-7-12T03:00:00Z","2010-7-15T05:59:59Z"):
System.Net.WebException: The request failed with HTTP status 505: HTTP Version Not Supported.

Prior to the 13th it worked as expected.
harolds
 
Posts: 1
Joined: Wed Jul 14, 2010 11:38 am

Re: 2010-07-13 outage *RESOLVED*

Postby rmeden » Wed Jul 14, 2010 1:26 pm

First, to new posters... sorry I didn't see your posts in the moderation queue for some reason. As you can imagine, things have been busy (both at SD and my day job :) )

re: HTTP Version not supported
I've seen this a few times in my tms_check script to.. it's not consistent. I'll report it.

re: Start time issue
I'll be reporting this...

(BTW, try and open a new topic for new issues... I don't mind you hijacking this thread since the outage is over, but other folks may not find it)

Robert
rmeden
SD Board Member
 
Posts: 1478
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX

Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 1 guest

cron