Page 1 of 1

JSON Service Not Responding

PostPosted: Sun Jul 24, 2016 4:07 am
by MrGrymReaper
Hi Everyone,

Just thought I would ask if anyone else is having an issue using the configuration (or grabbing) feature in xmltv with the JSON service and checking the address using a web browser. I'm currently getting an error code 500 from the json address which may be a standard HTTP error.

Basically an unable to connect error in both the xmltv software and a standard web browser program which is compounded by a site up or down checker website service tool (http://www.isup.me/json.schedulesdirect.org:443). All of which are giving up errors or messages which typically occur when a site is unavailable (down).

Are any of you guys having this issue as well feel free to chime in.

Thanks,

MrGrymReaper

Re: JSON Service Not Responding

PostPosted: Sun Jul 24, 2016 7:31 am
by rkulagow
Everything appears to be up; there are plenty of clients connected right now.

What do you get if you do an nslookup for json.schedulesdirect.org

It should be pointing at our loadbalancer:

Code: Select all
$ nslookup json.schedulesdirect.org
Server:         172.31.0.2
Address:        172.31.0.2#53

Non-authoritative answer:
json.schedulesdirect.org        canonical name = SD-LB-151222593.us-east-1.elb.amazonaws.com.
Name:   SD-LB-151222593.us-east-1.elb.amazonaws.com
Address: 52.202.36.92
Name:   SD-LB-151222593.us-east-1.elb.amazonaws.com
Address: 54.152.10.207
Name:   SD-LB-151222593.us-east-1.elb.amazonaws.com
Address: 54.164.175.14
Name:   SD-LB-151222593.us-east-1.elb.amazonaws.com
Address: 52.72.200.122

Re: JSON Service Not Responding

PostPosted: Sun Jul 24, 2016 1:28 pm
by MrGrymReaper
Hi,

I did a nslookup for the result see the screenshot. However my xmltv grabber is giving me an error code 500 when ever I try to configure the grabber and would likely do the same when running a grab. It is likely the same as an HTTP error or is it an undocumented error.

As a result it can't proceed with the initial configuration and thus do a grab.

Any idea what may be wrong please I'm running xmltv 0.5.68 and the tv_grab_sd_json grabber within the software under windows?

Thanks,

MrGrymReaper

Re: JSON Service Not Responding

PostPosted: Sun Jul 24, 2016 2:14 pm
by kgroeneveld
Everything is working fine for me at the moment, even though http://www.isup.me/json.schedulesdirect.org:443 says it is down. I am not sure exactly how that site tests a sight is up. Does it support https? Does it expect to see some actual content? https://json.schedulesdirect.org just returns an empty HTML document so maybe that isn't enough for isup to indicate the server is up.

If you are even getting errors (you should just get a blank page) when trying to access https://json.schedulesdirect.org in a browser then it is probably not an XMLTV specific problem. Maybe some sort of https/certificate issue on your computer? Or maybe some sort of https problem on your network/router? Have you tried from another computer or network?