Invalid User

Post Reply
mstone121
Posts: 9
Joined: Sat Jun 02, 2018 8:40 am

Invalid User

Post by mstone121 » Mon Aug 27, 2018 4:16 pm

Hello,

I recently purchased a a Schedules Direct account after my trial account expired. When I had the trial account I was able to get a token from the server, but now I get and INVALID_USER response.

Code: Select all

{"response":"INVALID_USER","code":4003,"serverID":"20141201.web.X","message":"Invalid username or token has expired.","datetime":"2018-08-26T15:44:37Z"}
I'm wondering if this has something to do with the fact that I let my trial account expire. Or maybe my purchased account hasn't been activated yet? I purchased it yesterday.

I've searched the forum and it seems like people have had similar issues but only after getting a token. I'm receiving this error on the /token route.

Matt

rmeden
SD Board Member
Posts: 1525
Joined: Tue Aug 14, 2007 2:31 pm
Location: Cedar Hill, TX
Contact:

Re: Invalid User

Post by rmeden » Tue Aug 28, 2018 8:22 am

I'm not an expert in the JSON service, but did you request a new token? They don't last forever... I think they're designed to use for one session.

mstone121
Posts: 9
Joined: Sat Jun 02, 2018 8:40 am

Re: Invalid User

Post by mstone121 » Wed Aug 29, 2018 8:47 am

I'm actually getting this error when requesting a token.

mstone121
Posts: 9
Joined: Sat Jun 02, 2018 8:40 am

Re: Invalid User

Post by mstone121 » Wed Aug 29, 2018 8:06 pm

Figured it out.

I was using my email address rather than my username.

Perhaps the API documentation should be updated to indicate this. Might save other people from the same frustration.
https://github.com/SchedulesDirect/JSON ... in-a-token

I'll submit a PR.

Matt

Post Reply