Page 1 of 1

station ID 21868 Showtime HD no data after 2015-10-04T15:00Z

Posted: Wed Sep 23, 2015 3:47 pm
by jagsd
Is something wrong with Station ID 21868 Showtime HD?

There is no new program data after 2015-10-04T15:00:00Z. All of my other stations have program info up to about 2015-10-14, 10 more days.

Note that /schedules returns dates out to 2015-10-14 but the programs arrays are empty.

Re: station ID 21868 Showtime HD no data after 2015-10-04T15

Posted: Wed Sep 23, 2015 5:51 pm
by rkulagow
I'm seeing the same on the server; I have a bulk load running now so lets see if it's still happening once it's complete.

Re: station ID 21868 Showtime HD no data after 2015-10-04T15

Posted: Thu Sep 24, 2015 8:23 am
by jagsd
rkulagow wrote:I'm seeing the same on the server; I have a bulk load running now so lets see if it's still happening once it's complete.
FYI, this did not fix the problem. Programs still missing.

Re: station ID 21868 Showtime HD no data after 2015-10-04T15

Posted: Thu Sep 24, 2015 8:36 am
by rkulagow
Yes, I'm stepping through the code now to see where it's doing the wrong thing.

Re: station ID 21868 Showtime HD no data after 2015-10-04T15

Posted: Thu Sep 24, 2015 9:08 am
by rkulagow
OK, found it. There's bad upstream data that was causing my code to do the wrong thing. It now handles the error better and allows schedules that are valid to be built. The update is running now.

Re: station ID 21868 Showtime HD no data after 2015-10-04T15

Posted: Thu Sep 24, 2015 10:18 am
by rkulagow
Can you check now?

Re: station ID 21868 Showtime HD no data after 2015-10-04T15

Posted: Thu Sep 24, 2015 12:05 pm
by jagsd
rkulagow wrote:Can you check now?
Looks good now. Thanks.