API 20141201 - Status endpoint returning invalid result

Post Reply
GameGod
Posts: 60
Joined: Fri Aug 17, 2007 12:26 pm

API 20141201 - Status endpoint returning invalid result

Post by GameGod » Tue Sep 08, 2015 9:48 am

Hi,

The /status endpoint is no longer returning the expected result in the "systemStatus" field.

Code: Select all

{
  "account": {
    "expires": "2016-06-21T22:18:29Z",
    "messages": [],
    "maxLineups": 4
  },
  "lineups": [
    {
      "lineup": "USA-CA04683-X",
      "modified": "2015-09-06T14:25:29Z",
      "uri": "/20141201/lineups/USA-CA04683-X"
    },
    {
      "lineup": "USA-OTA-94536",
      "modified": "2015-09-03T04:34:36Z",
      "uri": "/20141201/lineups/USA-OTA-94536"
    }
  ],
  "lastDataUpdate": "2015-09-07T19:18:13Z",
  "notifications": [],
  "systemStatus": [
    ""
  ],
  "serverID": "20141201.web.2",
  "code": 0
}
The systemStatus field is expected to return an object per the API:

Code: Select all

 "systemStatus": [
        {
            "date": "2012-12-17T16:24:47Z",
            "status": "Online",
            "details": "All servers running normally."
        }
    ],
Can this please be fixed ASAP, so I can get updated listing data?

Thanks.

rkulagow
SD Staff
Posts: 915
Joined: Tue Aug 14, 2007 3:15 pm

Re: API 20141201 - Status endpoint returning invalid result

Post by rkulagow » Tue Sep 08, 2015 10:39 am

Let me look into it. There should be a system status and now I'm wondering why it didn't generate an error in my reporting.

rkulagow
SD Staff
Posts: 915
Joined: Tue Aug 14, 2007 3:15 pm

Re: API 20141201 - Status endpoint returning invalid result

Post by rkulagow » Tue Sep 08, 2015 10:56 am

Can you check if you're still seeing an issue?

jagsd
Posts: 40
Joined: Sun Sep 09, 2007 10:52 am

Re: API 20141201 - Status endpoint returning invalid result

Post by jagsd » Tue Sep 08, 2015 11:04 am

I had the same problem. It now appears fixed.

But there has been no new data since 2015-09-07T19:18:13Z, almost 23 hours.

rkulagow
SD Staff
Posts: 915
Joined: Tue Aug 14, 2007 3:15 pm

Re: API 20141201 - Status endpoint returning invalid result

Post by rkulagow » Tue Sep 08, 2015 11:15 am

The update is running right now.

GameGod
Posts: 60
Joined: Fri Aug 17, 2007 12:26 pm

Re: API 20141201 - Status endpoint returning invalid result

Post by GameGod » Tue Sep 08, 2015 4:36 pm

I can confirm that this is fixed for me as well.

Thanks!

Post Reply